Foutmelding over filtering bij import tabel GrootboekMutaties / LedgerTransactions

SupportCategorie: Power BI Connector voor Exact OnlineFoutmelding over filtering bij import tabel GrootboekMutaties / LedgerTransactions
Arie van Klompenburg Medewerkers gevraagd 3 weken geleden

Bij het importeren van de tabel GrootboekMutaties krijg ik de fout melding “This endpoint has mandatory filtering applied.”

When importing the LedgerTransactions table I get the error message “This endpoint has mandatory filtering applied.”

1 antwoorden
Beste antwoord
Arie van Klompenburg Medewerkers beantwoord 3 weken geleden

Deze foutmelding is het gevolg van een wijziging in de Exact Online API. In versie 2.85 van de Power BI Connector is deze melding opgelost. Je kunt dit oplossen door de Power BI Connector te updaten naar de laatste versie, zie de uitleg op Installatie update.

Als je in een GetTable functie de API endpoint Bulk/Financial/TransactionLines gebruikt, dan is het door Exact vereist dat je filtert op beide velden FinancialYear én FinancialPeriod. Dus bijvoorbeeld ‘FinancialYear ge 2022 and FinancialPeriod ge 0’.

 

English:

This error message is caused by a change in the Exact Online API. This issue has been fixed in version 2.85 of the Power BI Connector. You can solve this by updating the Power BI Connector to the latest version, see the explanation on Updating the connector.

If you use the API endpoint Bulk/Financial/TransactionLines in a GetTable function, Exact requires that you filter on both fields FinancialYear and FinancialPeriod. So for example ‘FinancialYear ge 2022 and FinancialPeriod ge 0’.